【通达信公式】佛手向上(二次翻红)——指标公式源码

2013-12-08 10:41 阅读 858 次 评论关闭

通达信公式佛手向上二次翻红)——指标公式源码

 设计思路:
1.ma30向上;
2.diff,dea在零线之上;
3.diff线回调dea线附近时不死叉,又调头向上;
4.ma5大于ma10,ma10大于ma30;
5.量均线mav5>mav34;
6.当日是阳线}
所以在副图是显示 手 的图标就是 佛手向上的意思

DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26); DIF:EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED; DEA:EMA(DIF,9),COLORBLUE; MACD:2*(DIF-DEA),COLORSTICK;
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1; FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1); FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018; FH5:=FH1 AND FH2 AND MACD<0.10;
VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
AND DIFF>DEA AND MACD>REF(MACD,1) AND DIFF>0 AND DEA>0 AND MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1); 佛手:IF(VV,1,0),NODRAW; DRAWICON(佛手,0.06,11);
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW; 低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;  加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW; DRAWICON(二次翻红,-0.05,1);
DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;  DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW; XG:二次翻红 OR 低买 OR 加油,NODRAW;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW)); 支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC)); 今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW; 今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW; 明压:阻价,LINETHICK0,NODRAW; 明撑:支价,LINETHICK0,NODRAW;

 

指标公式使用教程:

买入技巧:MACD指标八种买入形态(图解)

版权声明:本文著作权归原作者所有,欢迎分享本文,谢谢支持!
转载请注明:【通达信公式】佛手向上(二次翻红)——指标公式源码 | 猎微网

评论已关闭!