【通达信公式】通达信指标源码合集下载

2013-01-11 12:01 阅读 609 次 评论关闭

通达信指标源码合集下载介绍

内容涵盖:

主图:

【股海英雄】修改版(主图)

【股海英雄选股】全仓买(选股)

【股海英雄预警】预警(选股)

【老雕三线开花】自编(主图)

【老雕三线选股】自编(选股)
副图:
【夜雨VOL】

【庄家抬轿】
【黑马趋势】
A1:3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:EMA(A1,5),LINETHICK2,COLOR6600FF;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),黑马线,'跑'),COLOR00FF00;
DRAWTEXT(CROSS(A1,黑马线)AND 黑马线<A5,黑马线,'黑马');
DRAWTEXT(CROSS(黑马线,A5)AND 趋势线<80,黑马线,'追涨');
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,'大黑马');
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
DRAWICON(底部 AND A3>REF(A3,1),25,4);
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0;
大势已去:IF(CROSS(黑马线,A1)AND 黑马线>70 AND 趋势线>80,90,100),COLORFF0000;

【庄见哭优化】
庄筹估算:WINNER(C)*100,COLORMAGENTA,LINETHICK2;
散筹估算:(WINNER(C*1.1)-WINNER(C*0.9))*100,COLORGREEN,LINETHICK2;
CC:=FILTER( (CROSS(5,庄筹估算) AND 散筹估算<20 )*60,10 );
抄底:CC,COLORYELLOW;
DRAWTEXT(CC ,11 ,'抄底' ) ,COLORYELLOW;
AA:= REF(庄筹估算,30)>40 OR REF(庄筹估算,20)>40;
BB:=CROSS(28,庄筹估算) AND 散筹估算>40 AND AA=1};
洗盘:IF(BB ,30 ,60 ) ,COLORCYAN;
DRAWTEXT(FILTER(BB,4) ,66 ,'洗盘' ) ,COLORCYAN;
DRAWTEXT(庄筹估算>60,58,'★'),COLORRED;
STICKLINE(庄筹估算<散筹估算 AND 散筹估算<60,散筹估算,55,1,0),COLORGREEN;
STICKLINE(庄筹估算>散筹估算,散筹估算,50,1,0),COLORRED;
STICKLINE(庄筹估算<散筹估算,庄筹估算,0,0,0),COLORYELLOW;

【极品DDX】
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORCYAN;
进出量:=买量+卖量,COLOR00FFFF;

STICKLINE(进出量<0,0,进出量,4,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;
STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;
STICKLINE(进出量<0,0,进出量,0.5,0),COLORCYAN;
STICKLINE(进出量>0,0,进出量,4,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,1.5,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;

N:=5;
M:=13;
N日内净流入:SUM(进出量,N),LINETHICK2,COLORGREEN;
流入:IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL),COLORRED,LINETHICK2;
连红天:BARSLASTCOUNT(进出量>0);
M日内翻红天:COUNT(进出量>0,M),COLORRED;

走熊天:BARSLASTCOUNT(N日内净流入<0),COLORCYAN;
走牛天:BARSLASTCOUNT(N日内净流入>0),COLORRED;
强势天:BARSLASTCOUNT((N日内净流入>REF(N日内净流入,1))>0 AND N日内净流入>0);
弱势天:BARSLASTCOUNT((N日内净流入<REF(N日内净流入,1))>0 AND N日内净流入<0);

【觅庄建仓】

【专吸庄血】

通达信指标源码合集下载地址

 【通达信公式】通达信指标源码合集下载

猎微网提醒您:股市有风险,投资须谨慎!

任何的指标公式仅能做参考学习之用!!

更多通达信经典指标公式

版权声明:本文著作权归原作者所有,欢迎分享本文,谢谢支持!
转载请注明:【通达信公式】通达信指标源码合集下载 | 猎微网

评论已关闭!